CVE-2025-3446 Members Without Guest Invite Permissions Can Add Guests to Teams
Authenticated users can improperly add guest users to teams despite lacking specific guest invite permissions, requiring an upgrade to Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3446?
CVE-2025-3446 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 15 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to check the correct permissions which allows authenticated users who only have permission to invite non-guest users to a team to add guest users to that team via the API to add a single user to a team.
Weakness: CWE-863
Which versions are affected by CVE-2025-3446?
14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250415054241-76ab3867b785 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250415054241-76ab3867b785 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250415054241-76ab3867b785 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.5 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.5 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.3 |
8 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0 | 10.6.2 |
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0 | 10.6.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.12 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.12 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.12+incompatible, 10.4.5+incompatible, 10.5.3+incompatible, 10.6.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-3446?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250415054241-76ab3867b785, 10.4.5, 10.5.3 or 10.6.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-3446 being exploited?
There is no known exploitation of CVE-2025-3446 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-r7r2-m3vr-c8qc, GO-2025-3693.