{"answers":{"affected":"3 open source packages ship an affected version, including cowrie. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34469 exists.","fix":"Upgrade cowrie to 2.9.0 or later.","what":"CVE-2025-34469 is a medium-severity server-side request forgery vulnerability in Cowrie, published on 31 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-34469 and fix it if it is affected.\n\nWhat it is: CVE-2025-34469 is a medium-severity server-side request forgery vulnerability in Cowrie, published on 31 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-34469 exists.\n\nAffected packages and fixed versions:\n- cowrie (PyPI): affected all versions; fixed in 2.9.0\n- cowrie (PyPI): affected all versions; fixed in 2.9.0\n- cowrie (PyPI): affected all versions; fixed in 2.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-34469/ (Markdown: https://insights.sbomify.com/CVE-2025-34469/index.md)","id":"CVE-2025-34469","markdown":"https://insights.sbomify.com/CVE-2025-34469/index.md","name":"CVE-2025-34469","record":{"aliases":["GHSA-83jg-m2pm-4jxj","PYSEC-2026-1280"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Cowrie honeypot","requires_auth":"none","summary":"Unauthenticated attackers can abuse Cowrie's emulated wget/curl to launch SSRF-based DDoS attacks against third parties, masking their identity.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"cowrie","vendor":"cowrie"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Cowrie versions prior to 2.9.0 contain a server-side request forgery (SSRF) vulnerability in the emulated shell implementation of wget and curl. In the default emulated shell configuration, these command emulations perform real outbound HTTP requests to attacker-supplied destinations. Because no outbound request rate limiting was enforced, unauthenticated remote attackers could repeatedly invoke these commands to generate unbounded HTTP traffic toward arbitrary third-party targets, allowing the Cowrie honeypot to be abused as a denial-of-service amplification node and masking the attacker’s true source address behind the honeypot’s IP.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cowrie \u003c 2.9.0 Unrestricted wget/curl Emulation Enables SSRF-Based DDoS Amplification","id":"CVE-2025-34469","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":3,"n_references":5,"next":{"headline":"This CVE ID was rejected because it was reserved but not used for a vulnerability disclosure.","id":"CVE-2025-34470"},"packages":[{"ecosystem":"PyPI","fixed":["2.9.0"],"introduced":["0"],"last_affected":[],"package":"cowrie","purl":null,"source":"GHSA-83jg-m2pm-4jxj"},{"ecosystem":"PyPI","fixed":["2.9.0"],"introduced":["0"],"last_affected":[],"package":"cowrie","purl":"pkg:pypi/cowrie","source":"GHSA-83jg-m2pm-4jxj"},{"ecosystem":"PyPI","fixed":["2.9.0"],"introduced":["0"],"last_affected":[],"package":"cowrie","purl":"pkg:pypi/cowrie","source":"PYSEC-2026-1280"}],"prev":{"headline":"libcoap Stack-Based Buffer Overflow in Address Resolution DoS or Potential RCE","id":"CVE-2025-34468"},"products":["Cowrie"],"published":"2025-12-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["Cowrie"]},"summary":"Unauthenticated attackers can abuse Cowrie's emulated wget/curl to launch SSRF-based DDoS attacks against third parties, masking their identity.","url":"https://insights.sbomify.com/CVE-2025-34469/"}