CVE-2025-34520 Arcserve UDP < 10.2 Authentication Bypass

High 7.7 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2025-34520?

CVE-2025-34520 is a high-severity vulnerability in Arcserve Unified Data Protection (UDP), published on 27 Aug 2025.

Official description

An authentication bypass vulnerability in Arcserve Unified Data Protection (UDP) allows unauthenticated attackers to gain unauthorized access to protected functionality or user accounts. By manipulating specific request parameters or exploiting a logic flaw, an attacker can bypass login mechanisms without valid credentials and access administrator-level features. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.

Weakness: CWE-288

Which versions are affected by CVE-2025-34520?

It affects 1 product.

Products include Arcserve Udp.

How do I fix CVE-2025-34520?

No fix has been published for CVE-2025-34520 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-34520 being exploited?

There is no known exploitation of CVE-2025-34520 in the wild and no public exploit code.

Sources

Also known as GHSA-27qr-6rgm-2f59.

Is CVE-2025-34520 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free