CVE-2025-34522 Arcserve UDP < 10.2 Pre-Authentication Heap Overflow

Critical 9.2 Published Updated

Pre-authentication heap overflow in Arcserve UDP allows remote attackers to execute code or crash the service via crafted input.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-34522?

CVE-2025-34522 is a critical memory corruption vulnerability in Arcserve Unified Data Protection (UDP), published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A heap-based buffer overflow vulnerability exists in the input parsing logic of Arcserve Unified Data Protection (UDP). This flaw can be triggered without authentication by sending specially crafted input to the target system. Improper bounds checking allows an attacker to overwrite heap memory, potentially leading to application crashes or remote code execution. Exploitation occurs in the context of the affected process and does not require user interaction. The vulnerability poses a high risk due to its pre-authentication nature and potential for full compromise. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.

Weakness: CWE-122

Which versions are affected by CVE-2025-34522?

It affects 1 product.

Products include Arcserve Udp.

How do I fix CVE-2025-34522?

No fix has been published for CVE-2025-34522 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-34522 being exploited?

There is no known exploitation of CVE-2025-34522 in the wild and no public exploit code.

Sources

Also known as GHSA-vvg7-q6v7-c4xg.

Is CVE-2025-34522 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free