# CVE-2025-34522: Arcserve UDP < 10.2 Pre-Authentication Heap Overflow

> Pre-authentication heap overflow in Arcserve UDP allows remote attackers to execute code or crash the service via crafted input.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Aug 2025
- **Updated:** 15 May 2026
- **Also known as:** GHSA-vvg7-q6v7-c4xg

## What is CVE-2025-34522?

CVE-2025-34522 is a critical memory corruption vulnerability in Arcserve Unified Data Protection (UDP), published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A heap-based buffer overflow vulnerability exists in the input parsing logic of Arcserve Unified Data Protection (UDP). This flaw can be triggered without authentication by sending specially crafted input to the target system. Improper bounds checking allows an attacker to overwrite heap memory, potentially leading to application crashes or remote code execution. Exploitation occurs in the context of the affected process and does not require user interaction. The vulnerability poses a high risk due to its pre-authentication nature and potential for full compromise. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-34522?

It affects 1 product.


Products: Arcserve Udp.

## How do I fix CVE-2025-34522?

No fix has been published for CVE-2025-34522 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-34522 being exploited?

There is no known exploitation of CVE-2025-34522 in the wild and no public exploit code.

## Other vulnerabilities in Arcserve Unified Data Protection (UDP)

- [CVE-2015-4068](https://insights.sbomify.com/CVE-2015-4068/): Arcserve Unified Data Protection (UDP) Directory Traversal (critical 9.1, exploited in the wild)
- [CVE-2024-0799](https://insights.sbomify.com/CVE-2024-0799/): Authentication Bypass via wizardLogin in Arcserve Unified Data Protection (critical 9.8)
- [CVE-2023-41998](https://insights.sbomify.com/CVE-2023-41998/): Arcserve UDP Unauthenticated RCE (critical 9.8)
- [CVE-2023-41999](https://insights.sbomify.com/CVE-2023-41999/): Arcserve UDP Management Authentication Bypass (critical 9.8)
- [CVE-2023-42000](https://insights.sbomify.com/CVE-2023-42000/): Arcserve UDP Agent Unauthenticated Path Traversal File Upload (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-34522 and fix it if it is affected.

What it is: CVE-2025-34522 is a critical memory corruption vulnerability in Arcserve Unified Data Protection (UDP), published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-34522 in the wild and no public exploit code.

Affected product: Arcserve Unified Data Protection (UDP). No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-34522/ (Markdown: https://insights.sbomify.com/CVE-2025-34522/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-34522
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-34522
- OSV: https://osv.dev/vulnerability/CVE-2025-34522

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-34522/
Summaries are generated and may contain mistakes; the official description above is the record.
