{"answers":{"affected":"1 open source package ship an affected version, including mediawiki.","exploited":"There is no known exploitation of CVE-2025-3469 in the wild and no public exploit code.","fix":"Upgrade mediawiki to 1.43.1 or later.","what":"CVE-2025-3469 is a cross-site scripting vulnerability in Wikimedia Foundation MediaWiki, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-3469 and fix it if it is affected.\n\nWhat it is: CVE-2025-3469 is a cross-site scripting vulnerability in Wikimedia Foundation MediaWiki, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-3469 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki (Bitnami): affected all versions; fixed in 1.43.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-3469/ (Markdown: https://insights.sbomify.com/CVE-2025-3469/index.md)","id":"CVE-2025-3469","markdown":"https://insights.sbomify.com/CVE-2025-3469/index.md","name":"CVE-2025-3469","record":{"aliases":["BIT-mediawiki-2025-3469","DEBIAN-CVE-2025-3469","GHSA-7jc7-7vhf-f7fg","UBUNTU-CVE-2025-3469"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki","requires_auth":"none","summary":"An XSS vulnerability in MediaWiki's HTMLMultiSelectField allows attackers to inject scripts, potentially leading to session hijacking or malicious actions.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"wikimedia-foundation","cpe":[],"cvss":{"score":0,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/RE:M/U:Green","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/htmlform/fields/HTMLMultiSelectField.Php.\n\nThis issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"i18n XSS vulnerability in HTMLMultiSelectField when sections are used","id":"CVE-2025-3469","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"SQL injection in TS Poll – Survey, Versus Poll, Image Poll, Video Poll","id":"CVE-2025-3470"},"packages":[{"ecosystem":"Bitnami","fixed":["1.43.1"],"introduced":["0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2025-3469"}],"prev":{"headline":"Cross-site scripting in NEX-Forms – Ultimate Forms Plugin for WordPress","id":"CVE-2025-3468"},"products":["MediaWiki"],"published":"2025-04-10","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["Wikimedia Foundation"]},"summary":"An XSS vulnerability in MediaWiki's HTMLMultiSelectField allows attackers to inject scripts, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2025-3469/"}