# CVE-2025-3501: Org.keycloak.protocol.services: keycloak hostname verification

> Attackers can bypass certificate verification in Keycloak by configuring a specific verification policy, potentially enabling man-in-the-middle attacks.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2025
- **Updated:** 21 Sep 2026
- **Also known as:** ECHO-32d8-b09c-5c73, GHSA-hw58-3793-42gg

## What is CVE-2025-3501?

CVE-2025-3501 is a high-severity vulnerability in Red Hat Build of Keycloak, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Keycloak. By setting a verification policy to 'ALL', the trust store certificate verification is skipped, which is unintended.

Weakness: CWE-297 (Improper Validation of Certificate with Host Mismatch)

## Which versions are affected by CVE-2025-3501?

2 open source packages ship an affected version, including org.keycloak:keycloak-services.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.2.2 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.2.2 |

## How do I fix CVE-2025-3501?

Upgrade org.keycloak:keycloak-services to 26.2.2 or later.

## Is CVE-2025-3501 being exploited?

There is no known exploitation of CVE-2025-3501 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3501 and fix it if it is affected.

What it is: CVE-2025-3501 is a high-severity vulnerability in Red Hat Build of Keycloak, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3501 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.2.2
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3501/ (Markdown: https://insights.sbomify.com/CVE-2025-3501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3501
- OSV: https://osv.dev/vulnerability/CVE-2025-3501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3501/
Summaries are generated and may contain mistakes; the official description above is the record.
