{"answers":{"affected":"8 open source packages ship an affected version, including org.hibernate.validator:hibernate-validator and org.hibernate:hibernate-validator. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-35036 exists.","fix":"Upgrade org.hibernate.validator:hibernate-validator to a fixed version for your release line: 6.2.0.CR1 or 7.0.0.CR1.","what":"CVE-2025-35036 is a medium-severity code injection vulnerability in Hibernate Validator, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-35036 and fix it if it is affected.\n\nWhat it is: CVE-2025-35036 is a medium-severity code injection vulnerability in Hibernate Validator, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-35036 exists.\n\nAffected packages and fixed versions:\n- org.hibernate.validator:hibernate-validator (Maven): affected all versions; fixed in 6.2.0.CR1\n- org.hibernate.validator:hibernate-validator (Maven): affected all versions; fixed in 6.2.0.CR1\n- org.hibernate.validator:hibernate-validator (Maven): affected from 7.0.0.Alpha1; fixed in 7.0.0.CR1\n- org.hibernate.validator:hibernate-validator (Maven): affected from 7.0.0.Alpha1; fixed in 7.0.0.CR1\n- org.hibernate:hibernate-validator (Maven): affected all versions; fixed in 6.2.0.CR1\n- org.hibernate:hibernate-validator (Maven): affected all versions; fixed in 6.2.0.CR1\n- org.hibernate:hibernate-validator (Maven): affected from 7.0.0.Alpha1; fixed in 7.0.0.CR1\n- org.hibernate:hibernate-validator (Maven): affected from 7.0.0.Alpha1; fixed in 7.0.0.CR1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-35036/ (Markdown: https://insights.sbomify.com/CVE-2025-35036/index.md)","id":"CVE-2025-35036","markdown":"https://insights.sbomify.com/CVE-2025-35036/index.md","name":"CVE-2025-35036","record":{"aliases":["DEBIAN-CVE-2025-35036","GHSA-7v6m-28jr-rg84","UBUNTU-CVE-2025-35036"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Java validation library","requires_auth":"none","summary":"Attackers can execute arbitrary Java code or access sensitive data via Expression Language injection in Hibernate Validator constraint messages.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"cisa-cg","cpe":[{"product":"hibernate_validator","vendor":"redhat"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Hibernate Validator before 6.2.0 and 7.0.0, by default and depending how it is used, may interpolate user-supplied input in a constraint violation message with Expression Language. This could allow an attacker to access sensitive information or execute arbitrary Java code. Hibernate Validator as of 6.2.0 and 7.0.0 no longer interpolates custom constraint violation messages with Expression Language and strongly recommends not allowing user-supplied input in constraint violation messages. CVE-2020-5245 and CVE-2025-4428 are examples of related, downstream vulnerabilities involving Expression Language intepolation of user-supplied data.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"hibernate-validator insecure default Expression Language interpolation","id":"CVE-2025-35036","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":8,"n_references":13,"next":{"headline":"Airship AI Acropolis MFA insufficient rate limiting","id":"CVE-2025-35041"},"packages":[{"ecosystem":"Maven","fixed":["6.2.0.CR1"],"introduced":["0"],"last_affected":[],"package":"org.hibernate.validator:hibernate-validator","purl":null,"source":"GHSA-7v6m-28jr-rg84"},{"ecosystem":"Maven","fixed":["6.2.0.CR1"],"introduced":["0"],"last_affected":[],"package":"org.hibernate.validator:hibernate-validator","purl":"pkg:maven/org.hibernate.validator/hibernate-validator","source":"GHSA-7v6m-28jr-rg84"},{"ecosystem":"Maven","fixed":["7.0.0.CR1"],"introduced":["7.0.0.Alpha1"],"last_affected":[],"package":"org.hibernate.validator:hibernate-validator","purl":null,"source":"GHSA-7v6m-28jr-rg84"},{"ecosystem":"Maven","fixed":["7.0.0.CR1"],"introduced":["7.0.0.Alpha1"],"last_affected":[],"package":"org.hibernate.validator:hibernate-validator","purl":"pkg:maven/org.hibernate.validator/hibernate-validator","source":"GHSA-7v6m-28jr-rg84"},{"ecosystem":"Maven","fixed":["6.2.0.CR1"],"introduced":["0"],"last_affected":[],"package":"org.hibernate:hibernate-validator","purl":null,"source":"GHSA-7v6m-28jr-rg84"},{"ecosystem":"Maven","fixed":["6.2.0.CR1"],"introduced":["0"],"last_affected":[],"package":"org.hibernate:hibernate-validator","purl":"pkg:maven/org.hibernate/hibernate-validator","source":"GHSA-7v6m-28jr-rg84"},{"ecosystem":"Maven","fixed":["7.0.0.CR1"],"introduced":["7.0.0.Alpha1"],"last_affected":[],"package":"org.hibernate:hibernate-validator","purl":null,"source":"GHSA-7v6m-28jr-rg84"},{"ecosystem":"Maven","fixed":["7.0.0.CR1"],"introduced":["7.0.0.Alpha1"],"last_affected":[],"package":"org.hibernate:hibernate-validator","purl":"pkg:maven/org.hibernate/hibernate-validator","source":"GHSA-7v6m-28jr-rg84"}],"prev":{"headline":"Medical Informatics Engineering Enterprise Health reflected cross site scripting via portlet_user_id","id":"CVE-2025-35034"},"products":["Hibernate Validator"],"published":"2025-06-03","related":[{"cvss_score":7,"headline":"Privilege Escalation in Hibernate Validator","id":"CVE-2017-7536","kev_date_added":null,"published":"2018-01-10"},{"cvss_score":5,"headline":"Improper Authentication in Hibernate Validator","id":"CVE-2014-3558","kev_date_added":null,"published":"2014-09-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-05","vendors":["Hibernate"]},"summary":"Attackers can execute arbitrary Java code or access sensitive data via Expression Language injection in Hibernate Validator constraint messages.","url":"https://insights.sbomify.com/CVE-2025-35036/"}