{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-3509 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-3509 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-3509 is a high-severity code injection vulnerability in Github Enterprise Server, published on 17 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-3509 and fix it if it is affected.\n\nWhat it is: CVE-2025-3509 is a high-severity code injection vulnerability in Github Enterprise Server, published on 17 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-3509 in the wild and no public exploit code.\n\nAffected product: Github Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-3509/ (Markdown: https://insights.sbomify.com/CVE-2025-3509/index.md)","id":"CVE-2025-3509","markdown":"https://insights.sbomify.com/CVE-2025-3509/index.md","name":"CVE-2025-3509","record":{"aliases":["GHSA-g3x6-r9w9-mcxx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"GitHub Enterprise Server","requires_auth":"high_privilege","summary":"Attackers with specific permissions can execute arbitrary code via pre-receive hooks during hot patch upgrades, leading to privilege escalation.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_P","cpe":[{"product":"enterprise_server","vendor":"github"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:L/SC:L/SI:H/SA:L/AU:N/R:U/V:C/RE:M/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"A Remote Code Execution (RCE) vulnerability was identified in GitHub Enterprise Server that allowed attackers to execute arbitrary code by exploiting the pre-receive hook functionality, potentially leading to privilege escalation and system compromise. The vulnerability involves using dynamically allocated ports that become temporarily available, such as during a hot patch upgrade. This means the vulnerability is only exploitable during specific operational conditions, which limits the attack window. Exploitation required either site administrator permissions to enable and configure pre-receive hooks or a user with permissions to modify repositories containing pre-receive hooks where this functionality was already enabled. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.17.1, 3.16.4, 3.15.8, 3.14.13, 3.13.16. This vulnerability was reported via the GitHub Bug Bounty program.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Code injection in Enterprise Server","id":"CVE-2025-3509","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"github:enterprise_server","products":["github:enterprise_server"],"type":"code_injection","year":"2025"},"n_packages":0,"n_references":5,"next":{"headline":"tagDiv Composer \u003c= 5.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Shortcodes","id":"CVE-2025-3510"},"packages":[],"prev":{"headline":"Certain HP DesignJet products – Information disclosure","id":"CVE-2025-3508"},"products":["Enterprise Server"],"published":"2025-04-17","related":[{"cvss_score":10,"headline":"Auth bypass in Enterprise Server","id":"CVE-2024-4985","kev_date_added":null,"published":"2024-05-20"},{"cvss_score":9.8,"headline":"Missing authorization in GitHub Enterprise Server","id":"CVE-2022-23739","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":9.8,"headline":"Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE","id":"CVE-2022-46255","kev_date_added":null,"published":"2022-12-14"},{"cvss_score":9.8,"headline":"Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group","id":"CVE-2021-22869","kev_date_added":null,"published":"2021-09-24"},{"cvss_score":9.5,"headline":"Auth bypass in Enterprise Server","id":"CVE-2024-9487","kev_date_added":null,"published":"2024-10-10"},{"cvss_score":9.5,"headline":"Auth bypass in GitHub Enterprise Server","id":"CVE-2024-6800","kev_date_added":null,"published":"2024-08-20"},{"cvss_score":9.3,"headline":"GitHub Enterprise Server notebook viewer vulnerable to Server-side request forgery","id":"CVE-2026-77987","kev_date_added":null,"published":"2026-09-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-18","vendors":["GitHub"]},"summary":"Attackers with specific permissions can execute arbitrary code via pre-receive hooks during hot patch upgrades, leading to privilege escalation.","url":"https://insights.sbomify.com/CVE-2025-3509/"}