# CVE-2025-3509: Code injection in Enterprise Server

> Attackers with specific permissions can execute arbitrary code via pre-receive hooks during hot patch upgrades, leading to privilege escalation.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:L/SC:L/SI:H/SA:L/AU:N/R:U/V:C/RE:M/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Apr 2025
- **Updated:** 18 Jun 2025
- **Also known as:** GHSA-g3x6-r9w9-mcxx

## What is CVE-2025-3509?

CVE-2025-3509 is a high-severity code injection vulnerability in Github Enterprise Server, published on 17 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A Remote Code Execution (RCE) vulnerability was identified in GitHub Enterprise Server that allowed attackers to execute arbitrary code by exploiting the pre-receive hook functionality, potentially leading to privilege escalation and system compromise. The vulnerability involves using dynamically allocated ports that become temporarily available, such as during a hot patch upgrade. This means the vulnerability is only exploitable during specific operational conditions, which limits the attack window. Exploitation required either site administrator permissions to enable and configure pre-receive hooks or a user with permissions to modify repositories containing pre-receive hooks where this functionality was already enabled. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.17.1, 3.16.4, 3.15.8, 3.14.13, 3.13.16. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-3509?

It affects 1 product.


Products: Github Enterprise Server.

## How do I fix CVE-2025-3509?

No fix has been published for CVE-2025-3509 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-3509 being exploited?

There is no known exploitation of CVE-2025-3509 in the wild and no public exploit code.

## Other vulnerabilities in Github Enterprise Server

- [CVE-2024-4985](https://insights.sbomify.com/CVE-2024-4985/): Auth bypass in Enterprise Server (critical 10.0)
- [CVE-2022-23739](https://insights.sbomify.com/CVE-2022-23739/): Missing authorization in GitHub Enterprise Server (critical 9.8)
- [CVE-2022-46255](https://insights.sbomify.com/CVE-2022-46255/): Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE (critical 9.8)
- [CVE-2021-22869](https://insights.sbomify.com/CVE-2021-22869/): Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group (critical 9.8)
- [CVE-2024-9487](https://insights.sbomify.com/CVE-2024-9487/): Auth bypass in Enterprise Server (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3509 and fix it if it is affected.

What it is: CVE-2025-3509 is a high-severity code injection vulnerability in Github Enterprise Server, published on 17 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3509 in the wild and no public exploit code.

Affected product: Github Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3509/ (Markdown: https://insights.sbomify.com/CVE-2025-3509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3509
- OSV: https://osv.dev/vulnerability/CVE-2025-3509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3509/
Summaries are generated and may contain mistakes; the official description above is the record.
