CVE-2025-3525 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

Authenticated users can cause denial of service by creating specially crafted CI triggers via the API in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-3525?

CVE-2025-3525 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 9.0 before 18.7.5, 18.8 before 18.8.5, and 18.9 before 18.9.1 that could have, under certain circumstances, allowed an authenticated user with certain access to cause Denial of Service by creating specially crafted CI triggers via the API.

Weakness: CWE-770

Which versions are affected by CVE-2025-3525?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.0.018.7.5, 18.8.5, 18.9.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-3525?

Upgrade gitlab to a fixed version for your release line: 18.7.5, 18.8.5 or 18.9.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-3525 being exploited?

There is no known exploitation of CVE-2025-3525 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-3525, GHSA-23hx-3f44-x72r, UBUNTU-CVE-2025-3525.

Is CVE-2025-3525 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free