# CVE-2025-3526: Liferay Portal SessionClicks does not restrict the saving of request parameters in the HTTP session

> Remote attackers can cause denial of service by exhausting system memory through unrestricted storage of HTTP request parameters in the session.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2025
- **Updated:** 16 Jun 2025
- **Also known as:** GHSA-mf3r-6m25-3867

## What is CVE-2025-3526?

CVE-2025-3526 is a high-severity denial of service vulnerability in Liferay Digital Experience Platform, published on 16 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SessionClicks in Liferay Portal 7.0.0 through 7.4.3.21, and Liferay DXP 7.4 GA through update 9, 7.3 GA through update 25, and older unsupported versions does not restrict the saving of request parameters in the HTTP session, which allows remote attackers to consume system memory leading to denial-of-service (DoS) conditions via crafted HTTP requests.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-3526?

2 open source packages ship an affected version, including com.liferay.portal:com.liferay.portal.kernel. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:com.liferay.portal.kernel` | Maven | All versions | 38.0.0 |
| `com.liferay.portal:com.liferay.portal.kernel` | Maven | All versions | 38.0.0 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-3526?

Upgrade com.liferay.portal:com.liferay.portal.kernel to 38.0.0 or later.

## Is CVE-2025-3526 being exploited?

There is no known exploitation of CVE-2025-3526 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3526 and fix it if it is affected.

What it is: CVE-2025-3526 is a high-severity denial of service vulnerability in Liferay Digital Experience Platform, published on 16 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3526 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:com.liferay.portal.kernel (Maven): affected all versions; fixed in 38.0.0
- com.liferay.portal:com.liferay.portal.kernel (Maven): affected all versions; fixed in 38.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3526/ (Markdown: https://insights.sbomify.com/CVE-2025-3526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3526
- OSV: https://osv.dev/vulnerability/CVE-2025-3526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3526/
Summaries are generated and may contain mistakes; the official description above is the record.
