CVE-2025-3527 Cross-site scripting in EventON (Pro) - WordPress Virtual Event Calendar Plugin
Authenticated subscribers can inject arbitrary scripts via missing capability checks, leading to stored XSS attacks against other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-3527?
CVE-2025-3527 is a medium-severity cross-site scripting vulnerability in EventON (Pro) - WordPress Virtual Event Calendar Plugin, published on 17 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The EventON Pro plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check in the 'assets/lib/settings/settings.js' file in all versions up to, and including, 4.9.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.9.6.
Weakness: CWE-862
Which versions are affected by CVE-2025-3527?
It affects 1 product.
Products include Myeventon Eventon.
How do I fix CVE-2025-3527?
No fix has been published for CVE-2025-3527 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-3527 being exploited?
There is no known exploitation of CVE-2025-3527 in the wild and no public exploit code.
Other vulnerabilities in EventON (Pro) - WordPress Virtual Event Calendar Plugin
- CVE-2023-6242 Cross-site request forgery in EventON (Pro) - WordPress Virtual Event Calendar Plugin
- CVE-2023-6244 Cross-site request forgery in EventON (Pro) - WordPress Virtual Event Calendar Plugin
- CVE-2023-6158 Missing authorization in EventON (Pro) - WordPress Virtual Event Calendar Plugin
- CVE-2023-7200 EventON < 4.4.1 - Reflected Cross-Site Scripting
- CVE-2024-0233 EventON (Free < 2.2.8, Premium < 4.5.5) - Reflected XSS
Sources
Also known as GHSA-4fg5-cfp9-9q4x.