# CVE-2025-3527: Cross-site scripting in EventON (Pro) - WordPress Virtual Event Calendar Plugin

> Authenticated subscribers can inject arbitrary scripts via missing capability checks, leading to stored XSS attacks against other users.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 May 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-4fg5-cfp9-9q4x

## What is CVE-2025-3527?

CVE-2025-3527 is a medium-severity cross-site scripting vulnerability in EventON (Pro) - WordPress Virtual Event Calendar Plugin, published on 17 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The EventON Pro plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check in the 'assets/lib/settings/settings.js' file in all versions up to, and including, 4.9.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.9.6.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-3527?

It affects 1 product.


Products: Myeventon Eventon.

## How do I fix CVE-2025-3527?

No fix has been published for CVE-2025-3527 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-3527 being exploited?

There is no known exploitation of CVE-2025-3527 in the wild and no public exploit code.

## Other vulnerabilities in EventON (Pro) - WordPress Virtual Event Calendar Plugin

- [CVE-2023-6242](https://insights.sbomify.com/CVE-2023-6242/): Cross-site request forgery in EventON (Pro) - WordPress Virtual Event Calendar Plugin (medium 6.5)
- [CVE-2023-6244](https://insights.sbomify.com/CVE-2023-6244/): Cross-site request forgery in EventON (Pro) - WordPress Virtual Event Calendar Plugin (medium 6.5)
- [CVE-2023-6158](https://insights.sbomify.com/CVE-2023-6158/): Missing authorization in EventON (Pro) - WordPress Virtual Event Calendar Plugin (medium 6.5)
- [CVE-2023-7200](https://insights.sbomify.com/CVE-2023-7200/): EventON < 4.4.1 - Reflected Cross-Site Scripting (medium 6.1)
- [CVE-2024-0233](https://insights.sbomify.com/CVE-2024-0233/): EventON (Free < 2.2.8, Premium < 4.5.5) - Reflected XSS (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3527 and fix it if it is affected.

What it is: CVE-2025-3527 is a medium-severity cross-site scripting vulnerability in EventON (Pro) - WordPress Virtual Event Calendar Plugin, published on 17 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3527 in the wild and no public exploit code.

Affected product: EventON (Pro) - WordPress Virtual Event Calendar Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3527/ (Markdown: https://insights.sbomify.com/CVE-2025-3527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3527
- OSV: https://osv.dev/vulnerability/CVE-2025-3527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3527/
Summaries are generated and may contain mistakes; the official description above is the record.
