{"answers":{"affected":"2 open source packages ship an affected version, including jquery-validation.","exploited":"There is no known exploitation of CVE-2025-3573 in the wild and no public exploit code.","fix":"Upgrade jquery-validation to 1.20.0 or later.","what":"CVE-2025-3573 is a medium-severity cross-site scripting vulnerability in jquery-validation, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-3573 and fix it if it is affected.\n\nWhat it is: CVE-2025-3573 is a medium-severity cross-site scripting vulnerability in jquery-validation, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-3573 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jquery-validation (npm): affected all versions; fixed in 1.20.0\n- jquery-validation (npm): affected all versions; fixed in 1.20.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-3573/ (Markdown: https://insights.sbomify.com/CVE-2025-3573/index.md)","id":"CVE-2025-3573","markdown":"https://insights.sbomify.com/CVE-2025-3573/index.md","name":"CVE-2025-3573","record":{"aliases":["DEBIAN-CVE-2025-3573","GHSA-rrj2-ph5q-jxw2","UBUNTU-CVE-2025-3573"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"jQuery validation library","requires_auth":"none","summary":"An attacker can execute arbitrary scripts via XSS in the showLabel function using user-controlled placeholder values in the jQuery Validation library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"jquery-validation vulnerable to Cross-site Scripting","id":"CVE-2025-3573","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Insecure Direct Object Reference on Deporsite by T-INNOVA","id":"CVE-2025-3574"},"packages":[{"ecosystem":"npm","fixed":["1.20.0"],"introduced":["0"],"last_affected":[],"package":"jquery-validation","purl":null,"source":"GHSA-rrj2-ph5q-jxw2"},{"ecosystem":"npm","fixed":["1.20.0"],"introduced":["0"],"last_affected":[],"package":"jquery-validation","purl":"pkg:npm/jquery-validation","source":"GHSA-rrj2-ph5q-jxw2"}],"prev":{"headline":"INTUMIT SmartRobot - Server-Side Request Forgery","id":"CVE-2025-3572"},"products":["jquery-validation"],"published":"2025-04-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["n/a"]},"summary":"An attacker can execute arbitrary scripts via XSS in the showLabel function using user-controlled placeholder values in the jQuery Validation library.","url":"https://insights.sbomify.com/CVE-2025-3573/"}