# CVE-2025-3573: jquery-validation vulnerable to Cross-site Scripting

> An attacker can execute arbitrary scripts via XSS in the showLabel function using user-controlled placeholder values in the jQuery Validation library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2025
- **Updated:** 15 Apr 2025
- **Also known as:** DEBIAN-CVE-2025-3573, GHSA-rrj2-ph5q-jxw2, UBUNTU-CVE-2025-3573

## What is CVE-2025-3573?

CVE-2025-3573 is a medium-severity cross-site scripting vulnerability in jquery-validation, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-3573?

2 open source packages ship an affected version, including jquery-validation.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jquery-validation` | npm | All versions | 1.20.0 |
| `jquery-validation` | npm | All versions | 1.20.0 |

## How do I fix CVE-2025-3573?

Upgrade jquery-validation to 1.20.0 or later.

## Is CVE-2025-3573 being exploited?

There is no known exploitation of CVE-2025-3573 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3573 and fix it if it is affected.

What it is: CVE-2025-3573 is a medium-severity cross-site scripting vulnerability in jquery-validation, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-3573 in the wild and no public exploit code.

Affected packages and fixed versions:
- jquery-validation (npm): affected all versions; fixed in 1.20.0
- jquery-validation (npm): affected all versions; fixed in 1.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3573/ (Markdown: https://insights.sbomify.com/CVE-2025-3573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3573
- OSV: https://osv.dev/vulnerability/CVE-2025-3573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3573/
Summaries are generated and may contain mistakes; the official description above is the record.
