# CVE-2025-3586: Liferay Portal and DXP Instance Admin can execute code using Objects Actions and Validations

> Authenticated admin users can execute arbitrary Groovy scripts via Object actions, leading to remote code execution.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-m5gv-vj3f-6v2p

## What is CVE-2025-3586?

CVE-2025-3586 is a high-severity code injection vulnerability in Liferay Digital Experience Platform, published on 1 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Liferay Portal 7.4.3.27 through 7.4.3.42, and Liferay DXP 2024.Q1.1 through 2024.Q1.20, 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.10, 7.4 update 27 through update 42 (Liferay PaaS, and Liferay Self-Hosted), the Objects module does not restrict the use of Groovy scripts in Object actions for Admin Users. This allows remote authenticated admin users with the Instance Administrator role to execute arbitrary Groovy scripts (i.e., remote code execution) through Object actions. 

In contrast, in Liferay DXP (Liferay SaaS), the use of Groovy in Object actions is not allowed due to the high security risks it poses. 

Starting from Liferay DXP 2024.Q2 and later, a new feature has been introduced in Instance Settings that allows administrators to configure whether Groovy scripts are allowed in their instances.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-3586?

2 open source packages ship an affected version, including com.liferay:com.liferay.object.service. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.object.service` | Maven | All versions | 1.0.96 |
| `com.liferay:com.liferay.object.service` | Maven | All versions | 1.0.96 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-3586?

Upgrade com.liferay:com.liferay.object.service to 1.0.96 or later.

## Is CVE-2025-3586 being exploited?

There is no known exploitation of CVE-2025-3586 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3586 and fix it if it is affected.

What it is: CVE-2025-3586 is a high-severity code injection vulnerability in Liferay Digital Experience Platform, published on 1 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3586 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.object.service (Maven): affected all versions; fixed in 1.0.96
- com.liferay:com.liferay.object.service (Maven): affected all versions; fixed in 1.0.96

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3586/ (Markdown: https://insights.sbomify.com/CVE-2025-3586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3586
- OSV: https://osv.dev/vulnerability/CVE-2025-3586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3586/
Summaries are generated and may contain mistakes; the official description above is the record.
