# CVE-2025-35965: DoS in Mattermost Playbooks via Excessive Task Actions

> An attacker can cause a denial of service in Mattermost by submitting excessive task actions via the GraphQL API, overloading the server.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2025
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-689c-xq7x-xjwf, GO-2025-3643

## What is CVE-2025-35965?

CVE-2025-35965 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 24 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to validate the uniqueness and quantity of task actions within the UpdateRunTaskActions GraphQL operation, which allows an attacker to create task items containing an excessive number of actions triggered by specific posts, overloading the server and leading to a denial-of-service (DoS) condition.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-35965?

21 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-plugin-playbooks and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.4.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.4.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | None |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | None |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | 1.41.0 |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | 1.41.0 |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | 1.41.0 |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | From 2.0.0 | None |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | From 2.0.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.4.0+incompatible | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0+incompatible | None |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0+incompatible | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-35965?

Upgrade github.com/mattermost/mattermost/server/v8 to 8.0.0-20250218121836-2b5275d87136 or later.

## Is CVE-2025-35965 being exploited?

There is no known exploitation of CVE-2025-35965 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-35965 and fix it if it is affected.

What it is: CVE-2025-35965 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 24 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-35965 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218121836-2b5275d87136
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218121836-2b5275d87136
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218121836-2b5275d87136
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.4.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.4.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; no fix listed
- github.com/mattermost/mattermost-plugin-playbooks (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-plugin-playbooks (Go): affected all versions; fixed in 1.41.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-35965/ (Markdown: https://insights.sbomify.com/CVE-2025-35965/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-35965
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-35965
- OSV: https://osv.dev/vulnerability/CVE-2025-35965

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-35965/
Summaries are generated and may contain mistakes; the official description above is the record.
