CVE-2025-3601 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can cause a Denial of Service in GitLab by submitting URLs that generate excessively large responses.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-3601?

CVE-2025-3601 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 27 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 8.15 before 18.1.5, 18.2 before 18.2.5, and 18.3 before 18.3.1 that could have could have allowed an authenticated user to cause a Denial of Service (DoS) condition by submitting URLs that generate excessively large responses.

Weakness: CWE-770

Which versions are affected by CVE-2025-3601?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.15.018.1.5, 18.2.5, 18.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-3601?

Upgrade gitlab to a fixed version for your release line: 18.1.5, 18.2.5 or 18.3.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-3601 being exploited?

There is no known exploitation of CVE-2025-3601 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-3601, GHSA-v8g6-hvf8-9cwq, MINI-43jw-r3f5-wh9p, MINI-ghrq-cw97-wm89, MINI-q56q-qr9w-rf42, MINI-vc3m-j836-4rwm and 4 more.

Is CVE-2025-3601 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free