# CVE-2025-3604: Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Account Takeover

> Unauthenticated attackers can change arbitrary user emails to reset passwords and take over accounts, including administrators, due to missing identity validation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Apr 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-8xcw-x64j-h58v

## What is CVE-2025-3604?

CVE-2025-3604 is a critical missing authorization vulnerability in v1rustyle Flynax Bridge, published on 24 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Flynax Bridge plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 2.2.0. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for unauthenticated attackers to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-3604?

It affects 1 product.


Products: Flynax Flynax Bridge.

## How do I fix CVE-2025-3604?

No fix has been published for CVE-2025-3604 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-3604 being exploited?

There is no known exploitation of CVE-2025-3604 in the wild and no public exploit code.

Public exploit code:

- Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Account Takeover (github_poc): https://github.com/Nxploited/CVE-2025-3604

## Other vulnerabilities in v1rustyle Flynax Bridge

- [CVE-2025-3603](https://insights.sbomify.com/CVE-2025-3603/): Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Password Update (critical 9.8)
- [CVE-2025-4179](https://insights.sbomify.com/CVE-2025-4179/): Flynax Bridge <= 2.2.0 - Unauthenticated Limited Privilege Escalation (high 7.3)
- [CVE-2025-4177](https://insights.sbomify.com/CVE-2025-4177/): Flynax Bridge <= 2.2.0 - Unauthenticated Arbitrary User Deletion (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3604 and fix it if it is affected.

What it is: CVE-2025-3604 is a critical missing authorization vulnerability in v1rustyle Flynax Bridge, published on 24 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3604 in the wild and no public exploit code.

Affected product: v1rustyle Flynax Bridge. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3604/ (Markdown: https://insights.sbomify.com/CVE-2025-3604/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3604
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3604
- OSV: https://osv.dev/vulnerability/CVE-2025-3604

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3604/
Summaries are generated and may contain mistakes; the official description above is the record.
