CVE-2025-3611 Improper Access Control in Mattermost allows System Managers to view team details despite role restrictions
System Managers can bypass access restrictions to view unauthorized team details via direct API requests, exposing sensitive organizational data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3611?
CVE-2025-3611 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 30 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.7.x <= 10.7.0, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fails to properly enforce access control restrictions for System Manager roles, allowing authenticated users with System Manager privileges to view team details they should not have access to via direct API requests to team endpoints, even when explicitly configured with 'No access' to Teams in the System Console.
Weakness: CWE-863
Which versions are affected by CVE-2025-3611?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250414154356-6f33b721de76 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250414154356-6f33b721de76 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250414154356-6f33b721de76 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0-rc1 | 10.5.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0-rc1 | 10.5.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0-rc1 | 10.7.1 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0-rc1 | 10.7.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0-rc1 | 9.11.13 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0-rc1 | 9.11.13 |
github.com/mattermost/mattermost-server Go | From 9.0.0-rc1+incompatible | 9.11.13+incompatible, 10.5.4+incompatible, 10.7.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-3611?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250414154356-6f33b721de76, 10.5.4, 10.7.1 or 9.11.13.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-3611 being exploited?
There is no known exploitation of CVE-2025-3611 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-86jg-35xj-3vv5, GO-2025-3728.