# CVE-2025-3616: Greenshift 11.4 - 11.4.5 - Authenticated (Subscriber+) Arbitrary File Upload

> Authenticated attackers can upload arbitrary files via missing validation, potentially leading to remote code execution on WordPress sites using the Greenshift plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Apr 2025
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-42rf-mpmc-c2vf

## What is CVE-2025-3616?

CVE-2025-3616 is a high-severity vulnerability in wpsoul Greenshift – animation and page builder blocks, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the gspb_make_proxy_api_request() function in versions 11.4 to 11.4.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The arbitrary file upload was sufficiently patched in 11.4.5, but a capability check was added in 11.4.6 to properly prevent unauthorized limited file uploads.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2025-3616?

It affects 1 product.


Products: Greenshiftwp Greenshift - Animation and Page Builder Blocks.

## How do I fix CVE-2025-3616?

No fix has been published for CVE-2025-3616 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-3616 being exploited?

There is no known exploitation of CVE-2025-3616 in the wild and no public exploit code.

Public exploit code:

- https://github.com/b4d-53ct0r/CVE-2025-3616 (github_poc): https://github.com/b4d-53ct0r/CVE-2025-3616

## Other vulnerabilities in wpsoul Greenshift – animation and page builder blocks

- [CVE-2025-26884](https://insights.sbomify.com/CVE-2025-26884/): WordPress Greenshift plugin <= 10.8 - Cross Site Scripting (XSS) vulnerability (medium 6.5)
- [CVE-2024-6155](https://insights.sbomify.com/CVE-2024-6155/): Server-side request forgery in Greenshift – animation and page builder blocks (medium 6.4)
- [CVE-2024-50419](https://insights.sbomify.com/CVE-2024-50419/): WordPress Greenshift plugin <=9.7 - Broken Access Control vulnerability (medium 5.4)
- [CVE-2024-11181](https://insights.sbomify.com/CVE-2024-11181/): Greenshift – animation and page builder blocks <= 9.9.9.3 - Authenticated (Contributor+) Post Disclosure (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3616 and fix it if it is affected.

What it is: CVE-2025-3616 is a high-severity vulnerability in wpsoul Greenshift – animation and page builder blocks, published on 22 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3616 in the wild and no public exploit code.

Affected product: wpsoul Greenshift – animation and page builder blocks. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3616/ (Markdown: https://insights.sbomify.com/CVE-2025-3616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3616
- OSV: https://osv.dev/vulnerability/CVE-2025-3616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3616/
Summaries are generated and may contain mistakes; the official description above is the record.
