# CVE-2025-3623: Uncanny Automator <= 6.4.0.1 - Unauthenticated PHP Object Injection in automator_api_decode_message Function

> Unauthenticated attackers can exploit PHP object injection to delete arbitrary files via a POP chain in the Uncanny Automator plugin.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 May 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-35ch-876f-6mw7

## What is CVE-2025-3623?

CVE-2025-3623 is a critical unsafe deserialization vulnerability in uncannyowl Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin, published on 14 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Uncanny Automator plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 6.4.0.1 via deserialization of untrusted input in the automator_api_decode_message() function. This makes it possible for unauthenticated to inject a PHP Object. The additional presence of a POP chain allows attackers to delete arbitrary files.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-3623?

It affects 1 product.


Products: Uncannyowl Uncanny Automator.

## How do I fix CVE-2025-3623?

No fix has been published for CVE-2025-3623 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-3623 being exploited?

There is no known exploitation of CVE-2025-3623 in the wild and no public exploit code.

## Other vulnerabilities in uncannyowl Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin

- [CVE-2025-2075](https://insights.sbomify.com/CVE-2025-2075/): Uncanny Automator <= 6.3.0.2 - Missing Authorization to Authenticated (Subscriber+) Privilege Escalation (high 8.8)
- [CVE-2024-37117](https://insights.sbomify.com/CVE-2024-37117/): WordPress Uncanny Automator Pro plugin <= 5.3 - Reflected Cross Site Scripting (XSS) vulnerability (high 7.1)
- [CVE-2025-48133](https://insights.sbomify.com/CVE-2025-48133/): WordPress Uncanny Automator plugin <= 6.4.0.2 - Broken Access Control Vulnerability (medium 6.5)
- [CVE-2024-13838](https://insights.sbomify.com/CVE-2024-13838/): Server-side request forgery in Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin (medium 5.5)
- [CVE-2025-4520](https://insights.sbomify.com/CVE-2025-4520/): Uncanny Automator <= 6.4.0.2 - Missing Authorization to Authenticated (Subscriber+) Plugin Settings Update (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3623 and fix it if it is affected.

What it is: CVE-2025-3623 is a critical unsafe deserialization vulnerability in uncannyowl Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin, published on 14 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3623 in the wild and no public exploit code.

Affected product: uncannyowl Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3623/ (Markdown: https://insights.sbomify.com/CVE-2025-3623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3623
- OSV: https://osv.dev/vulnerability/CVE-2025-3623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3623/
Summaries are generated and may contain mistakes; the official description above is the record.
