CVE-2025-3625 Moodle: user dos and name disclosure via idor in moodle mfa email factor revoke action
Attackers can revoke other users' MFA email factors, causing denial of service and disclosing sensitive user information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3625?
CVE-2025-3625 is a high-severity missing authorization vulnerability in Moodle Moodle, published on 25 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A security vulnerability was discovered in Moodle that can allow hackers to gain access to sensitive information about students and prevent them from logging into their accounts, even after they had completed two-factor authentication (2FA).
Weakness: CWE-639
Which versions are affected by CVE-2025-3625?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | From 4.3.0 | 4.3.12, 4.4.8, 4.5.4 |
Products include Moodle Moodle.
How do I fix CVE-2025-3625?
Upgrade moodle to a fixed version for your release line: 4.3.12, 4.4.8 or 4.5.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-3625 being exploited?
There is no known exploitation of CVE-2025-3625 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-3625, GHSA-57p3-67r2-vwm7, UBUNTU-CVE-2025-3625.