CVE-2025-3627 Moodle: partial data exposure in moodle before completing multi-factor authentication
Attackers can access sensitive student data before completing multi-factor authentication, requiring Moodle administrators to apply security patches.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3627?
CVE-2025-3627 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 25 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A security vulnerability was discovered in Moodle that allows some users to access sensitive information about other students before they finish verifying their identities using two-factor authentication (2FA).
Weakness: CWE-287
Which versions are affected by CVE-2025-3627?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 4.3.0-beta | 4.3.12 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.12 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.8 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.8 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.4 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.4 |
1 more packages
moodle Bitnami | From 4.3.0 | 4.3.12, 4.4.8, 4.5.4 |
Products include Moodle Moodle.
How do I fix CVE-2025-3627?
Upgrade moodle/moodle to a fixed version for your release line: 4.3.12, 4.4.8 or 4.5.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-3627 being exploited?
There is no known exploitation of CVE-2025-3627 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-3627, GHSA-x45j-jq9q-gf3q, UBUNTU-CVE-2025-3627.