{"answers":{"affected":"9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-3636 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 4.1.18, 4.3.12, 4.4.8 or 4.5.4.","what":"CVE-2025-3636 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 25 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-3636 and fix it if it is affected.\n\nWhat it is: CVE-2025-3636 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 25 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-3636 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 4.1.18\n- moodle/moodle (Packagist): affected all versions; fixed in 4.1.18\n- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.12\n- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.12\n- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.8\n- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.8\n- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.4\n- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.4\n- moodle (Bitnami): affected all versions; fixed in 4.1.18, 4.3.12, 4.4.8, 4.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-3636/ (Markdown: https://insights.sbomify.com/CVE-2025-3636/index.md)","id":"CVE-2025-3636","markdown":"https://insights.sbomify.com/CVE-2025-3636/index.md","name":"CVE-2025-3636","record":{"aliases":["BIT-moodle-2025-3636","GHSA-chmf-m33p-ph8m","UBUNTU-CVE-2025-3636"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Attackers can bypass capability checks to view unauthorized RSS feeds in Moodle, exposing sensitive information.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"A flaw was found in Moodle. This vulnerability allows unauthorized users to access and view RSS feeds due to insufficient capability checks.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle: idor in moodle rss block allows unauthorized access to rss feeds","id":"CVE-2025-3636","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"missing_authorization","year":"2025"},"n_packages":9,"n_references":3,"next":{"headline":"Moodle: csrf token exposure via url in moodle mod_data module","id":"CVE-2025-3637"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.18","4.3.12","4.4.8","4.5.4"],"introduced":["0","4.3.0","4.4.0","4.5.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2025-3636"},{"ecosystem":"Packagist","fixed":["4.1.18"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-chmf-m33p-ph8m"},{"ecosystem":"Packagist","fixed":["4.1.18"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-chmf-m33p-ph8m"},{"ecosystem":"Packagist","fixed":["4.3.12"],"introduced":["4.3.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-chmf-m33p-ph8m"},{"ecosystem":"Packagist","fixed":["4.3.12"],"introduced":["4.3.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-chmf-m33p-ph8m"},{"ecosystem":"Packagist","fixed":["4.4.8"],"introduced":["4.4.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-chmf-m33p-ph8m"},{"ecosystem":"Packagist","fixed":["4.4.8"],"introduced":["4.4.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-chmf-m33p-ph8m"},{"ecosystem":"Packagist","fixed":["4.5.4"],"introduced":["4.5.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-chmf-m33p-ph8m"},{"ecosystem":"Packagist","fixed":["4.5.4"],"introduced":["4.5.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-chmf-m33p-ph8m"}],"prev":{"headline":"Moodle: csrf risk in moodle user tours manager allows tour duplication","id":"CVE-2025-3635"},"products":["moodle:moodle"],"published":"2025-04-25","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-25","vendors":["moodle"]},"summary":"Attackers can bypass capability checks to view unauthorized RSS feeds in Moodle, exposing sensitive information.","url":"https://insights.sbomify.com/CVE-2025-3636/"}