CVE-2025-3637 Moodle: csrf token exposure via url in moodle mod_data module
Attackers can obtain CSRF tokens from URLs in Moodle's mod_data module, enabling cross-site request forgery attacks against users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3637?
CVE-2025-3637 is a low-severity vulnerability in Moodle Moodle, published on 25 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A security vulnerability was found in Moodle where confidential information that prevents cross-site request forgery (CSRF) attacks was shared publicly through the site's URL. This vulnerability occurred specifically on two types of pages within the mod_data module: edit and delete pages.
Weakness: CWE-598
Which versions are affected by CVE-2025-3637?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.3.12 |
moodle/moodle Packagist | All versions | 4.3.12 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.12 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.12 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.8 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.8 |
3 more packages
moodle/moodle Packagist | From 4.5.0-beta | 4.5.4 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.4 |
moodle Bitnami | All versions | 4.3.12, 4.4.8, 4.5.4 |
Products include Moodle Moodle.
How do I fix CVE-2025-3637?
Upgrade moodle/moodle to a fixed version for your release line: 4.3.12, 4.4.8 or 4.5.4.
Is CVE-2025-3637 being exploited?
There is no known exploitation of CVE-2025-3637 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-3637, GHSA-9vc3-vm42-fjhm, UBUNTU-CVE-2025-3637.