# CVE-2025-3637: Moodle: csrf token exposure via url in moodle mod_data module

> Attackers can obtain CSRF tokens from URLs in Moodle's mod_data module, enabling cross-site request forgery attacks against users.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2025
- **Updated:** 25 Apr 2025
- **Also known as:** BIT-moodle-2025-3637, GHSA-9vc3-vm42-fjhm, UBUNTU-CVE-2025-3637

## What is CVE-2025-3637?

CVE-2025-3637 is a low-severity vulnerability in Moodle Moodle, published on 25 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security vulnerability was found in Moodle where confidential information that prevents cross-site request forgery (CSRF) attacks was shared publicly through the site's URL. This vulnerability occurred specifically on two types of pages within the mod_data module: edit and delete pages.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String)

## Which versions are affected by CVE-2025-3637?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.3.12 |
| `moodle/moodle` | Packagist | All versions | 4.3.12 |
| `moodle/moodle` | Packagist | From 4.3.0-beta | 4.3.12 |
| `moodle/moodle` | Packagist | From 4.3.0-beta | 4.3.12 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.8 |
| `moodle/moodle` | Packagist | From 4.4.0-beta | 4.4.8 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.4 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.4 |
| `moodle` | Bitnami | All versions | 4.3.12, 4.4.8, 4.5.4 |

Products: Moodle Moodle.

## How do I fix CVE-2025-3637?

Upgrade moodle/moodle to a fixed version for your release line: 4.3.12, 4.4.8 or 4.5.4.

## Is CVE-2025-3637 being exploited?

There is no known exploitation of CVE-2025-3637 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3637 and fix it if it is affected.

What it is: CVE-2025-3637 is a low-severity vulnerability in Moodle Moodle, published on 25 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3637 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.3.12
- moodle/moodle (Packagist): affected all versions; fixed in 4.3.12
- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.12
- moodle/moodle (Packagist): affected from 4.3.0-beta; fixed in 4.3.12
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.8
- moodle/moodle (Packagist): affected from 4.4.0-beta; fixed in 4.4.8
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.4
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.4
- moodle (Bitnami): affected all versions; fixed in 4.3.12, 4.4.8, 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3637/ (Markdown: https://insights.sbomify.com/CVE-2025-3637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3637
- OSV: https://osv.dev/vulnerability/CVE-2025-3637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3637/
Summaries are generated and may contain mistakes; the official description above is the record.
