CVE-2025-3643 Moodle: reflected xss risk in policy tool
Attackers can execute arbitrary scripts in victim browsers via unsanitized return URLs in the Moodle policy tool.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-3643?
CVE-2025-3643 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A flaw was found in Moodle. The return URL in the policy tool required additional sanitizing to prevent a reflected Cross-site scripting (XSS) risk.
Weakness: CWE-79
Which versions are affected by CVE-2025-3643?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.18 |
moodle/moodle Packagist | All versions | 4.1.18 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.12 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.12 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.8 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.8 |
3 more packages
moodle/moodle Packagist | From 4.5.0-beta | 4.5.4 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.4 |
moodle Bitnami | All versions | 4.1.18, 4.3.12, 4.4.8, 4.5.4 |
Products include Moodle Moodle.
How do I fix CVE-2025-3643?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.18, 4.3.12, 4.4.8 or 4.5.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-3643 being exploited?
There is no known exploitation of CVE-2025-3643 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-3643, GHSA-hxgg-4qww-85ph, UBUNTU-CVE-2025-3643.