CVE-2025-3647 Moodle: idor when accessing the cohorts report
Attackers can access unauthorized cohort data in Moodle due to missing authorization checks in the cohorts report.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3647?
CVE-2025-3647 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 25 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was discovered in Moodle. Additional checks were required to ensure that users can only access cohort data they are authorized to retrieve.
Weakness: CWE-863
Which versions are affected by CVE-2025-3647?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.18 |
moodle/moodle Packagist | All versions | 4.1.18 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.12 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.12 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.8 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.8 |
3 more packages
moodle/moodle Packagist | From 4.5.0-beta | 4.5.4 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.4 |
moodle Bitnami | All versions | 4.1.18, 4.3.12, 4.4.8, 4.5.4 |
Products include Moodle Moodle.
How do I fix CVE-2025-3647?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.18, 4.3.12, 4.4.8 or 4.5.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-3647 being exploited?
There is no known exploitation of CVE-2025-3647 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-3647, GHSA-34g7-pg9j-pxgp, UBUNTU-CVE-2025-3647.