CVE-2025-36530 Import Path Traversal Enables Unauthorized Unsigned Plugin Installation

Medium 6.8 Published Updated

Restricted admins can install unauthorized plugins via path traversal, bypassing signature checks and potentially executing code.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-36530?

CVE-2025-36530 is a medium-severity path traversal vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Mattermost versions 10.9.x <= 10.9.1, 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate file paths during plugin import operations which allows restricted admin users to install unauthorized custom plugins via path traversal in the import functionality, bypassing plugin signature enforcement and marketplace restrictions.

Weakness: CWE-22

Which versions are affected by CVE-2025-36530?

18 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.9
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.9
github.com/mattermost/mattermost-server GoFrom 10.8.010.8.4
github.com/mattermost/mattermost-server GoFrom 10.8.010.8.4
github.com/mattermost/mattermost-server GoFrom 10.9.010.9.2
github.com/mattermost/mattermost-server GoFrom 10.9.010.9.2
12 more packages
github.com/mattermost/mattermost-server GoFrom 9.11.09.11.18
github.com/mattermost/mattermost-server GoFrom 9.11.09.11.18
github.com/mattermost/mattermost-server GoFrom 9.11.0+incompatible9.11.18+incompatible, 10.5.9+incompatible, 10.8.4+incompatible, 10.9.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v5 GoAll versions to 5.11.1None
github.com/mattermost/mattermost-server/v5 GoAll versions to 5.11.1None
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versions to 6.7.2None
github.com/mattermost/mattermost-server/v6 GoAll versions to 6.7.2None
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250619095651-9dd0b3943e55
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250619095651-9dd0b3943e55

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-36530?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.9, 10.8.4, 10.9.2 or 9.11.18.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-36530 being exploited?

There is no known exploitation of CVE-2025-36530 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-gq3r-5833-5532, GO-2025-3901.

Is CVE-2025-36530 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free