CVE-2025-36855 EOL .NET 6.0 Runtime Remote Code Execution Vulnerability
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2025-36855?
CVE-2025-36855 is a high-severity vulnerability in Microsoft .NET 6.0, published on 8 Sep 2025.
Official description
A vulnerability ( CVE-2025-21176 https://www.cve.org/CVERecord ) exists in DiaSymReader.dll due to buffer over-read.
Per CWE-126: Buffer Over-read https://cwe.mitre.org/data/definitions/126.html , Buffer Over-read is when a product reads from a buffer using buffer access mechanisms such as indexes or pointers that reference memory locations after the targeted buffer.
This issue affects EOL ASP.NET 6.0.0 <= 6.0.36 as represented in this CVE, as well as 8.0.0 <= 8.0.11 & <= 9.0.0 as represented in CVE-2025-21176.
Additionally, if you've deployed self-contained applications https://docs.microsoft.com/dotnet/core/deploying/#self-contained-deployments-scd targeting any of the impacted versions, these applications are also vulnerable and must be recompiled and redeployed.
NOTE: This CVE affects only End Of Life (EOL) software components. The vendor, Microsoft, has indicated there will be no future updates nor support provided upon inquiry.
Weakness: CWE-126
Which versions are affected by CVE-2025-36855?
2 open source packages ship an affected version, including dotnet and dotnet-sdk.
| Package | Affected | Fixed in |
|---|---|---|
dotnet Bitnami | From 6.0.0 | 6.0.36 |
dotnet-sdk Bitnami | From 6.0.0 | 6.0.36 |
How do I fix CVE-2025-36855?
Upgrade dotnet to 6.0.36 or later.
Is CVE-2025-36855 being exploited?
There is no known exploitation of CVE-2025-36855 in the wild and no public exploit code.
Sources
Also known as BIT-dotnet-2025-36855, BIT-dotnet-sdk-2025-36855, GHSA-642h-ggvv-j2c4.