# CVE-2025-36855: EOL .NET 6.0 Runtime Remote Code Execution Vulnerability


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Sep 2025
- **Updated:** 8 Sep 2025
- **Also known as:** BIT-dotnet-2025-36855, BIT-dotnet-sdk-2025-36855, GHSA-642h-ggvv-j2c4

## What is CVE-2025-36855?

CVE-2025-36855 is a high-severity vulnerability in Microsoft .NET 6.0, published on 8 Sep 2025. 

### Official description

A vulnerability ( CVE-2025-21176 https://www.cve.org/CVERecord ) exists in DiaSymReader.dll due to buffer over-read.

 Per  CWE-126: Buffer Over-read https://cwe.mitre.org/data/definitions/126.html , Buffer Over-read is when a product reads from a buffer using buffer access mechanisms such as indexes or pointers that reference memory locations after the targeted buffer.

  This issue affects EOL ASP.NET 6.0.0 <= 6.0.36 as represented in this CVE, as well as 8.0.0 <= 8.0.11 & <= 9.0.0 as represented in CVE-2025-21176.

 

 Additionally, if you've deployed  self-contained applications https://docs.microsoft.com/dotnet/core/deploying/#self-contained-deployments-scd  targeting any of the impacted versions, these applications are also vulnerable and must be recompiled and redeployed.

 NOTE: This CVE affects only End Of Life (EOL) software components. The vendor, Microsoft, has indicated there will be no future updates nor support provided upon inquiry.

Weakness: CWE-126 (Buffer Over-read)

## Which versions are affected by CVE-2025-36855?

2 open source packages ship an affected version, including dotnet and dotnet-sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dotnet` | Bitnami | From 6.0.0 | 6.0.36 |
| `dotnet-sdk` | Bitnami | From 6.0.0 | 6.0.36 |

## How do I fix CVE-2025-36855?

Upgrade dotnet to 6.0.36 or later.

## Is CVE-2025-36855 being exploited?

There is no known exploitation of CVE-2025-36855 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-36855 and fix it if it is affected.

What it is: CVE-2025-36855 is a high-severity vulnerability in Microsoft .NET 6.0, published on 8 Sep 2025. 
Exploitation: There is no known exploitation of CVE-2025-36855 in the wild and no public exploit code.

Affected packages and fixed versions:
- dotnet (Bitnami): affected from 6.0.0; fixed in 6.0.36
- dotnet-sdk (Bitnami): affected from 6.0.0; fixed in 6.0.36

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-36855/ (Markdown: https://insights.sbomify.com/CVE-2025-36855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-36855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-36855
- OSV: https://osv.dev/vulnerability/CVE-2025-36855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-36855/
Summaries are generated and may contain mistakes; the official description above is the record.
