# CVE-2025-3740: Path traversal in School Management System for Wordpress

> Authenticated attackers can exploit Local File Inclusion to execute arbitrary code and escalate privileges to Super Administrator in Multisite environments.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jul 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-9v44-8jj7-j768

## What is CVE-2025-3740?

CVE-2025-3740 is a high-severity path traversal vulnerability in dasinfomedia School Management System for Wordpress, published on 18 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The School Management System for Wordpress plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 93.1.0 via the 'page' parameter. This makes it possible for authenticated attackers, with Subscriber-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included. The Local File Inclusion exploit can be chained to include various dashboard view files in the plugin. One such chain can be leveraged to update the password of Super Administrator accounts in Multisite environments making privilege escalation possible. The vendor has updated the version numbers beginning with `1.93.1 (02-07-2025)` for the patched version. This version comes after version 93.1.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-3740?


## How do I fix CVE-2025-3740?

No fix has been published for CVE-2025-3740 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-3740 being exploited?

There is no known exploitation of CVE-2025-3740 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3740 and fix it if it is affected.

What it is: CVE-2025-3740 is a high-severity path traversal vulnerability in dasinfomedia School Management System for Wordpress, published on 18 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3740 in the wild and no public exploit code.

Affected product: dasinfomedia School Management System for Wordpress. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3740/ (Markdown: https://insights.sbomify.com/CVE-2025-3740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3740
- OSV: https://osv.dev/vulnerability/CVE-2025-3740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3740/
Summaries are generated and may contain mistakes; the official description above is the record.
