# CVE-2025-3757: Authentication Bypass in OpenPubKey

> A specially crafted JWS can bypass signature verification in the OpenPubKey library, allowing attackers to circumvent authentication mechanisms.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:L/SI:L/SA:L/AU:Y`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2025
- **Updated:** 13 May 2025
- **Also known as:** DEBIAN-CVE-2025-3757, GHSA-537f-gxgm-3jjq, GO-2025-3679, UBUNTU-CVE-2025-3757

## What is CVE-2025-3757?

CVE-2025-3757 is a critical authentication bypass vulnerability in OPKSSH, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of OpenPubkey library prior to 0.10.0  contained a vulnerability that would allow a specially crafted JWS to bypass signature verification.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2025-3757?

3 open source packages ship an affected version, including github.com/openpubkey/openpubkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openpubkey/openpubkey` | Go | All versions | 0.10.0 |
| `github.com/openpubkey/openpubkey` | Go | All versions | 0.10.0 |
| `github.com/openpubkey/openpubkey` | Go | All versions | 0.10.0 |

Products: Openpubkey Openpubkey.

## How do I fix CVE-2025-3757?

Upgrade github.com/openpubkey/openpubkey to 0.10.0 or later.

## Is CVE-2025-3757 being exploited?

There is no known exploitation of CVE-2025-3757 in the wild and no public exploit code.

## Other vulnerabilities in OPKSSH

- [CVE-2025-4658](https://insights.sbomify.com/CVE-2025-4658/): Authentication Bypass in OPKSSH (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3757 and fix it if it is affected.

What it is: CVE-2025-3757 is a critical authentication bypass vulnerability in OPKSSH, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3757 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openpubkey/openpubkey (Go): affected all versions; fixed in 0.10.0
- github.com/openpubkey/openpubkey (Go): affected all versions; fixed in 0.10.0
- github.com/openpubkey/openpubkey (Go): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3757/ (Markdown: https://insights.sbomify.com/CVE-2025-3757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3757
- OSV: https://osv.dev/vulnerability/CVE-2025-3757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3757/
Summaries are generated and may contain mistakes; the official description above is the record.
