# CVE-2025-3777: Improper Input Validation in huggingface/transformers

> Attackers can bypass URL validation to redirect users to malicious domains, enabling phishing or malware distribution in Hugging Face Transformers.

- **Severity:** Low 3.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** GHSA-phhr-52qp-3mj4, PYSEC-2026-1986

## What is CVE-2025-3777?

CVE-2025-3777 is a low-severity vulnerability in huggingface/transformers, published on 7 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Hugging Face Transformers versions up to 4.49.0 are affected by an improper input validation vulnerability in the `image_utils.py` file. The vulnerability arises from insecure URL validation using the `startswith()` method, which can be bypassed through URL username injection. This allows attackers to craft URLs that appear to be from YouTube but resolve to malicious domains, potentially leading to phishing attacks, malware distribution, or data exfiltration. The issue is fixed in version 4.52.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-3777?

3 open source packages ship an affected version, including transformers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transformers` | PyPI | All versions | 4.52.1 |
| `transformers` | PyPI | All versions | 4.52.1 |
| `transformers` | PyPI | All versions | 4.52.1 |

Products: Huggingface Transformers.

## How do I fix CVE-2025-3777?

Upgrade transformers to 4.52.1 or later.

## Is CVE-2025-3777 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3777 exists.

## Other vulnerabilities in huggingface/transformers

- [CVE-2023-7018](https://insights.sbomify.com/CVE-2023-7018/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.6)
- [CVE-2023-6730](https://insights.sbomify.com/CVE-2023-6730/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.0)
- [CVE-2024-11393](https://insights.sbomify.com/CVE-2024-11393/): Hugging Face Transformers MaskFormer Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2024-11394](https://insights.sbomify.com/CVE-2024-11394/): Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2026-5241](https://insights.sbomify.com/CVE-2026-5241/): Policy Bypass in LightGlue Nested Config Resolution in huggingface/transformers (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3777 and fix it if it is affected.

What it is: CVE-2025-3777 is a low-severity vulnerability in huggingface/transformers, published on 7 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3777 exists.

Affected packages and fixed versions:
- transformers (PyPI): affected all versions; fixed in 4.52.1
- transformers (PyPI): affected all versions; fixed in 4.52.1
- transformers (PyPI): affected all versions; fixed in 4.52.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3777/ (Markdown: https://insights.sbomify.com/CVE-2025-3777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3777
- OSV: https://osv.dev/vulnerability/CVE-2025-3777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3777/
Summaries are generated and may contain mistakes; the official description above is the record.
