# CVE-2025-3857: Infinite loop condition in Amazon.IonDotnet

> An infinite loop in Amazon.IonDotnet's binary reader allows attackers to cause denial of service via malformed data.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-gm2p-wf5c-w3pj

## What is CVE-2025-3857?

CVE-2025-3857 is a high-severity denial of service vulnerability in Amazon Ion Dotnet, published on 21 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When reading binary Ion data through Amazon.IonDotnet using the RawBinaryReader class, Amazon.IonDotnet does not check the number of bytes read from the underlying stream while deserializing the binary format. If the Ion data is malformed or truncated, this triggers an infinite loop condition that could potentially result in a denial of service. Users should upgrade to Amazon.IonDotnet version 1.3.1 and ensure any forked or derivative code is patched to incorporate the new fixes.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-3857?

2 open source packages ship an affected version, including Amazon.IonDotnet.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Amazon.IonDotnet` | NuGet | All versions | 1.3.1 |
| `Amazon.IonDotnet` | NuGet | All versions | 1.3.1 |

## How do I fix CVE-2025-3857?

Upgrade Amazon.IonDotnet to 1.3.1 or later.

## Is CVE-2025-3857 being exploited?

There is no known exploitation of CVE-2025-3857 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3857 and fix it if it is affected.

What it is: CVE-2025-3857 is a high-severity denial of service vulnerability in Amazon Ion Dotnet, published on 21 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3857 in the wild and no public exploit code.

Affected packages and fixed versions:
- Amazon.IonDotnet (NuGet): affected all versions; fixed in 1.3.1
- Amazon.IonDotnet (NuGet): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3857/ (Markdown: https://insights.sbomify.com/CVE-2025-3857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3857
- OSV: https://osv.dev/vulnerability/CVE-2025-3857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3857/
Summaries are generated and may contain mistakes; the official description above is the record.
