CVE-2025-3913 Team Privacy Settings Authorization Bypass in Mattermost Server
Team administrators lacking invite permissions can modify team invite IDs, bypassing intended access controls in Mattermost server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3913?
CVE-2025-3913 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 29 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to properly validate permissions when changing team privacy settings, allowing team administrators without the 'invite user' permission to access and modify team invite IDs via the /api/v4/teams/:teamId/privacy endpoint.
Weakness: CWE-863
Which versions are affected by CVE-2025-3913?
14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250412152950-02c76784380a |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250412152950-02c76784380a |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250412152950-02c76784380a |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0-rc1 | 10.5.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0-rc1 | 10.5.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0-rc1 | 10.6.3 |
8 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0-rc1 | 10.6.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.7.0-rc1 | 10.7.1 |
github.com/mattermost/mattermost/server/v8 Go | From 10.7.0-rc1 | 10.7.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0-rc1 | 9.11.13 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0-rc1 | 9.11.13 |
github.com/mattermost/mattermost-server Go | From 9.0.0-rc1+incompatible | 9.11.13+incompatible, 10.5.4+incompatible, 10.6.3+incompatible, 10.7.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-3913?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250412152950-02c76784380a, 10.5.4, 10.6.3 or 10.7.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-3913 being exploited?
There is no known exploitation of CVE-2025-3913 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-4mmr-2w8p-whcr, GO-2025-3724.