# CVE-2025-3913: Team Privacy Settings Authorization Bypass in Mattermost Server

> Team administrators lacking invite permissions can modify team invite IDs, bypassing intended access controls in Mattermost server.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2025
- **Updated:** 29 May 2025
- **Also known as:** GHSA-4mmr-2w8p-whcr, GO-2025-3724

## What is CVE-2025-3913?

CVE-2025-3913 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 29 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to properly validate permissions when changing team privacy settings, allowing team administrators without the 'invite user' permission to access and modify team invite IDs via the /api/v4/teams/:teamId/privacy endpoint.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-3913?

14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250412152950-02c76784380a |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250412152950-02c76784380a |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250412152950-02c76784380a |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0-rc1 | 10.5.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0-rc1 | 10.5.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.6.0-rc1 | 10.6.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.6.0-rc1 | 10.6.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.7.0-rc1 | 10.7.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.7.0-rc1 | 10.7.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.0.0-rc1 | 9.11.13 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.0.0-rc1 | 9.11.13 |
| `github.com/mattermost/mattermost-server` | Go | From 9.0.0-rc1+incompatible | 9.11.13+incompatible, 10.5.4+incompatible, 10.6.3+incompatible, 10.7.1+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-3913?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250412152950-02c76784380a, 10.5.4, 10.6.3 or 10.7.1.

## Is CVE-2025-3913 being exploited?

There is no known exploitation of CVE-2025-3913 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3913 and fix it if it is affected.

What it is: CVE-2025-3913 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 29 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3913 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250412152950-02c76784380a
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250412152950-02c76784380a
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250412152950-02c76784380a
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0-rc1; fixed in 10.5.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0-rc1; fixed in 10.5.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.6.0-rc1; fixed in 10.6.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.6.0-rc1; fixed in 10.6.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.7.0-rc1; fixed in 10.7.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.7.0-rc1; fixed in 10.7.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.0.0-rc1; fixed in 9.11.13
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.0.0-rc1; fixed in 9.11.13
- github.com/mattermost/mattermost-server (Go): affected from 9.0.0-rc1+incompatible; fixed in 9.11.13+incompatible, 10.5.4+incompatible, 10.6.3+incompatible, 10.7.1+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3913/ (Markdown: https://insights.sbomify.com/CVE-2025-3913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3913
- OSV: https://osv.dev/vulnerability/CVE-2025-3913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3913/
Summaries are generated and may contain mistakes; the official description above is the record.
