CVE-2025-3919 Cross-site scripting in Comments Import & Export

Medium 6.4 Published Updated

Authenticated subscribers can inject scripts into plugin settings, leading to code execution when admins view the page.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-3919?

CVE-2025-3919 is a medium-severity cross-site scripting vulnerability in webtoffee Comments Import & Export, published on 2 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The WordPress Comments Import & Export plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_settings function in all versions up to, and including, 2.4.3. Additionally, the plugin fails to properly sanitize and escape FTP settings parameters. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts on the plugin settings page that will execute whenever an administrative user accesses an injected page. The vulnerability was partially fixed in version 2.4.3 and fully fixed in version 2.4.4

Weakness: CWE-79

Which versions are affected by CVE-2025-3919?

How do I fix CVE-2025-3919?

No fix has been published for CVE-2025-3919 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-3919 being exploited?

There is no known exploitation of CVE-2025-3919 in the wild and no public exploit code.

Sources

Also known as GHSA-98qc-7j3q-5cm9.

Is CVE-2025-3919 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free