CVE-2025-3922 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can cause denial of service by overwhelming system resources via the GraphQL API due to insufficient limits.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-3922?

CVE-2025-3922 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.4 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that could have allowed an authenticated user to cause denial of service by overwhelming system resources under certain conditions due to insufficient resource allocation limits in the GraphQL API.

Weakness: CWE-770

Which versions are affected by CVE-2025-3922?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.4.018.9.6, 18.10.4, 18.11.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-3922?

Upgrade gitlab to a fixed version for your release line: 18.9.6, 18.10.4 or 18.11.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-3922 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3922 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-3922, GHSA-q9qr-p283-j9rm, UBUNTU-CVE-2025-3922.

Is CVE-2025-3922 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free