{"answers":{"affected":"2 open source packages ship an affected version, including @strapi/strapi.","exploited":"There is no known exploitation of CVE-2025-3930 in the wild and no public exploit code.","fix":"Upgrade @strapi/strapi to 5.24.1 or later.","what":"CVE-2025-3930 is a medium-severity vulnerability in Strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-3930 and fix it if it is affected.\n\nWhat it is: CVE-2025-3930 is a medium-severity vulnerability in Strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-3930 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @strapi/strapi (npm): affected all versions; fixed in 5.24.1\n- @strapi/strapi (npm): affected all versions; fixed in 5.24.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-3930/ (Markdown: https://insights.sbomify.com/CVE-2025-3930/index.md)","id":"CVE-2025-3930","markdown":"https://insights.sbomify.com/CVE-2025-3930/index.md","name":"CVE-2025-3930","record":{"aliases":["GHSA-4r8w-3jww-m2rp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Strapi CMS","requires_auth":"none","summary":"Attackers can reuse stolen JWTs after logout or account deactivation, enabling persistent unauthorized access to Strapi admin interfaces.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CERT-PL","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, which allows an attacker who has stolen or intercepted the token to freely reuse it until its expiration date (which is set to 30 days by default, but can be changed). \nThe existence of /admin/renew-token endpoint allows anyone to renew near-expiration tokens indefinitely, further increasing the impact of this attack. \n\nThis issue has been fixed in version 5.24.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Lack of JWT Expiration after Log Out in Strapi","id":"CVE-2025-3930","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Yggdrasil: local privilege escalation in yggdrasil","id":"CVE-2025-3931"},"packages":[{"ecosystem":"npm","fixed":["5.24.1"],"introduced":["0"],"last_affected":[],"package":"@strapi/strapi","purl":null,"source":"GHSA-4r8w-3jww-m2rp"},{"ecosystem":"npm","fixed":["5.24.1"],"introduced":["0"],"last_affected":[],"package":"@strapi/strapi","purl":"pkg:npm/%40strapi/strapi","source":"GHSA-4r8w-3jww-m2rp"}],"prev":{"headline":"Stored XSS vulnerability in MDaemon Email Server","id":"CVE-2025-3929"},"products":["Strapi"],"published":"2025-10-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-22","vendors":["Strapi"]},"summary":"Attackers can reuse stolen JWTs after logout or account deactivation, enabling persistent unauthorized access to Strapi admin interfaces.","url":"https://insights.sbomify.com/CVE-2025-3930/"}