# CVE-2025-3930: Lack of JWT Expiration after Log Out in Strapi

> Attackers can reuse stolen JWTs after logout or account deactivation, enabling persistent unauthorized access to Strapi admin interfaces.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 22 Oct 2025
- **Also known as:** GHSA-4r8w-3jww-m2rp

## What is CVE-2025-3930?

CVE-2025-3930 is a medium-severity vulnerability in Strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, which allows an attacker who has stolen or intercepted the token to freely reuse it until its expiration date (which is set to 30 days by default, but can be changed). 
The existence of /admin/renew-token endpoint allows anyone to renew near-expiration tokens indefinitely, further increasing the impact of this attack. 

This issue has been fixed in version 5.24.1.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-3930?

2 open source packages ship an affected version, including @strapi/strapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/strapi` | npm | All versions | 5.24.1 |
| `@strapi/strapi` | npm | All versions | 5.24.1 |

## How do I fix CVE-2025-3930?

Upgrade @strapi/strapi to 5.24.1 or later.

## Is CVE-2025-3930 being exploited?

There is no known exploitation of CVE-2025-3930 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3930 and fix it if it is affected.

What it is: CVE-2025-3930 is a medium-severity vulnerability in Strapi, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3930 in the wild and no public exploit code.

Affected packages and fixed versions:
- @strapi/strapi (npm): affected all versions; fixed in 5.24.1
- @strapi/strapi (npm): affected all versions; fixed in 5.24.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3930/ (Markdown: https://insights.sbomify.com/CVE-2025-3930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3930
- OSV: https://osv.dev/vulnerability/CVE-2025-3930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3930/
Summaries are generated and may contain mistakes; the official description above is the record.
