CVE-2025-3950 Exposure of Private Personal Information to an Unauthorized Actor in GitLab

Low 3.5 Published Updated

An attacker can leak private personal information by referencing specially crafted images that bypass asset proxy protection in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-3950?

CVE-2025-3950 is a low-severity vulnerability in Gitlab Gitlab, published on 9 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.3 before 18.5.5, 18.6 before 18.6.3, and 18.7 before 18.7.1 that could have allowed a user to leak certain information by referencing specially crafted images that bypass asset proxy protection.

Weakness: CWE-359

Which versions are affected by CVE-2025-3950?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 10.3.018.5.5, 18.6.3, 18.7.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-3950?

Upgrade gitlab to a fixed version for your release line: 18.5.5, 18.6.3 or 18.7.1.

Is CVE-2025-3950 being exploited?

There is no known exploitation of CVE-2025-3950 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-3950, GHSA-6mpj-fw9g-9wqm, UBUNTU-CVE-2025-3950.

Is CVE-2025-3950 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free