# CVE-2025-4001: scipopt scip File Descriptor genRandomLOPInstance.c main file descriptor consumption

> A local attacker can cause denial of service by exhausting file descriptors in the SCIP optimization library's example code.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Apr 2025
- **Updated:** 28 Apr 2025
- **Also known as:** GHSA-62xf-w58m-88wm

## What is CVE-2025-4001?

CVE-2025-4001 is a medium-severity denial of service vulnerability in scipopt scip, published on 28 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been found in scipopt scip up to 9.2.1 and classified as problematic. Affected by this vulnerability is the function main of the file examples/LOP/src/genRandomLOPInstance.c of the component File Descriptor Handler. The manipulation of the argument File leads to uncontrolled file descriptor consumption. Local access is required to approach this attack. Upgrading to version 9.2.2 is able to address this issue. The identifier of the patch is d6da63b941216d75fbc1aefea9abf1de6712a2d0. It is recommended to upgrade the affected component.

Weakness: CWE-769 (DEPRECATED: Uncontrolled File Descriptor Consumption), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-4001?


## How do I fix CVE-2025-4001?

No fix has been published for CVE-2025-4001 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-4001 being exploited?

There is no known exploitation of CVE-2025-4001 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4001 and fix it if it is affected.

What it is: CVE-2025-4001 is a medium-severity denial of service vulnerability in scipopt scip, published on 28 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4001 in the wild and no public exploit code.

Affected product: scipopt scip. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4001/ (Markdown: https://insights.sbomify.com/CVE-2025-4001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4001
- OSV: https://osv.dev/vulnerability/CVE-2025-4001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4001/
Summaries are generated and may contain mistakes; the official description above is the record.
