# CVE-2025-40843: Buffer overflow in CodeChecker log command

> A buffer overflow in CodeChecker's log command allows attackers to execute arbitrary code via crafted inputs.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2025
- **Updated:** 28 Oct 2025
- **Also known as:** GHSA-5xf2-f6ch-6p8r, PYSEC-2025-100

## What is CVE-2025-40843?

CVE-2025-40843 is a medium-severity memory corruption vulnerability in Ericsson CodeChecker, published on 28 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

CodeChecker is an analyzer tooling, defect database and viewer extension for the Clang Static Analyzer and Clang Tidy. 

CodeChecker versions up to 6.26.1 contain a buffer overflow vulnerability in the internal ldlogger library, which is executed by the CodeChecker log command.

This issue affects CodeChecker: through 6.26.1.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2025-40843?

3 open source packages ship an affected version, including codechecker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codechecker` | PyPI | All versions | 6.26.2 |
| `codechecker` | PyPI | All versions | 6.26.2 |
| `codechecker` | PyPI | All versions | 6.26.2 |

Products: Ericsson Codechecker.

## How do I fix CVE-2025-40843?

Upgrade codechecker to 6.26.2 or later.

## Is CVE-2025-40843 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-40843 exists.

## Other vulnerabilities in Ericsson CodeChecker

- [CVE-2024-10081](https://insights.sbomify.com/CVE-2024-10081/): codechecker vulnerable to authentication bypass when using specifically crafted URLs (critical 10.0)
- [CVE-2026-25660](https://insights.sbomify.com/CVE-2026-25660/): Authentication bypass for certain API calls (critical 9.3)
- [CVE-2024-10082](https://insights.sbomify.com/CVE-2024-10082/): codechecker authentication method confusion vulnerability allows logging in as the built-in root user from an external service (high 8.7)
- [CVE-2024-53829](https://insights.sbomify.com/CVE-2024-53829/): Cross-Site Request Forgery in CodeChecker API (high 8.2)
- [CVE-2023-49793](https://insights.sbomify.com/CVE-2023-49793/): Path traversal in `CodeChecker server` in the endpoint of `CodeChecker store` (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-40843 and fix it if it is affected.

What it is: CVE-2025-40843 is a medium-severity memory corruption vulnerability in Ericsson CodeChecker, published on 28 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-40843 exists.

Affected packages and fixed versions:
- codechecker (PyPI): affected all versions; fixed in 6.26.2
- codechecker (PyPI): affected all versions; fixed in 6.26.2
- codechecker (PyPI): affected all versions; fixed in 6.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-40843/ (Markdown: https://insights.sbomify.com/CVE-2025-40843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-40843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-40843
- OSV: https://osv.dev/vulnerability/CVE-2025-40843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-40843/
Summaries are generated and may contain mistakes; the official description above is the record.
