{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-40914 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-40914 is a critical vulnerability in MIK CryptX, published on 11 Jun 2025."},"fix_prompt":"Check this codebase for CVE-2025-40914 and fix it if it is affected.\n\nWhat it is: CVE-2025-40914 is a critical vulnerability in MIK CryptX, published on 11 Jun 2025. \nExploitation: There is no known exploitation of CVE-2025-40914 in the wild and no public exploit code.\n\nAffected product: MIK CryptX. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-40914/ (Markdown: https://insights.sbomify.com/CVE-2025-40914/index.md)","id":"CVE-2025-40914","markdown":"https://insights.sbomify.com/CVE-2025-40914/index.md","name":"CVE-2025-40914","record":{"aliases":["AZL-63927","DEBIAN-CVE-2025-40914","UBUNTU-CVE-2025-40914","openSUSE-SU-2025:15259-1"],"analysis":null,"analysis_generated_by":null,"assigner":"CPANSec","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1395","name":"Dependency on Vulnerable Third-Party Component"}],"description":"Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow.\n\nCryptX embeds a version of the libtommath library that is susceptible to an integer overflow associated with CVE-2023-36328.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Perl CryptX before version 0.087 contains a dependency that may be susceptible to an integer overflow","id":"CVE-2025-40914","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2025"},"n_packages":1,"n_references":4,"next":{"headline":"Mojolicious::Plugin::CSRF 1.03 for Perl uses a weak random number source for generating CSRF tokens","id":"CVE-2025-40915"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.87.0-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-CryptX","purl":"pkg:rpm/opensuse/perl-CryptX\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15259-1"}],"prev":{"headline":"Net::Dropbear versions through 0.16 for Perl contains a dependency that may be susceptible to an integer overflow","id":"CVE-2025-40913"},"products":["CryptX"],"published":"2025-06-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-11","vendors":["MIK"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2025-40914/"}