{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-40927 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-40927 is a high-severity cross-site scripting vulnerability in MANWAR CGI::Simple, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-40927 and fix it if it is affected.\n\nWhat it is: CVE-2025-40927 is a high-severity cross-site scripting vulnerability in MANWAR CGI::Simple, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-40927 in the wild and no public exploit code.\n\nAffected product: MANWAR CGI::Simple. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-40927/ (Markdown: https://insights.sbomify.com/CVE-2025-40927/index.md)","id":"CVE-2025-40927","markdown":"https://insights.sbomify.com/CVE-2025-40927/index.md","name":"CVE-2025-40927","record":{"aliases":["DEBIAN-CVE-2025-40927","GHSA-wh29-fq99-4ww5","UBUNTU-CVE-2025-40927","openSUSE-SU-2025:15625-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl CGI library","requires_auth":"none","summary":"Attackers can inject HTTP headers via URL-encoded newlines in CGI::Simple, enabling reflected XSS and open redirects.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-113","name":"Improper Neutralization of CRLF Sequences in HTTP Headers"}],"description":"CGI::Simple versions before 1.282 for Perl has a HTTP response splitting flaw\nThis vulnerability is a confirmed HTTP response splitting flaw in CGI::Simple that allows HTTP response header injection, which can be used for reflected XSS or open redirect under certain conditions.\n\nAlthough some validation exists, it can be bypassed using URL-encoded values, allowing an attacker to inject untrusted content into the response via query parameters.\n\nAs a result, an attacker can inject a line break (e.g. %0A) into the parameter value, causing the server to split the HTTP response and inject arbitrary headers or even an HTML/JavaScript body, leading to reflected cross-site scripting (XSS), open redirect or other attacks.\n\nThe issue documented in CVE-2010-4410 https://www.cve.org/CVERecord?id=CVE-2010-4410 is related but the fix was incomplete.\n\nImpact\n\nBy injecting %0A (newline) into a query string parameter, an attacker can:\n\n  *  Break the current HTTP header\n  *  Inject a new header or entire body\n  *  Deliver a script payload that is reflected in the server’s response\nThat can lead to the following attacks:\n\n  *  reflected XSS\n  *  open redirect\n  *  cache poisoning\n  *  header manipulation","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CGI::Simple versions 1.281 and earlier for Perl has a HTTP response splitting flaw","id":"CVE-2025-40927","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":1,"n_references":6,"next":{"headline":"Integer overflow in JSON::XS","id":"CVE-2025-40928"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.282.0-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-CGI-Simple","purl":"pkg:rpm/opensuse/perl-CGI-Simple\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15625-1"}],"prev":{"headline":"Plack::Middleware::Session::Simple versions before 0.05 for Perl generates session ids insecurely","id":"CVE-2025-40926"},"products":["CGI::Simple"],"published":"2025-08-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-29","vendors":["MANWAR"]},"summary":"Attackers can inject HTTP headers via URL-encoded newlines in CGI::Simple, enabling reflected XSS and open redirects.","url":"https://insights.sbomify.com/CVE-2025-40927/"}