{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-40929 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-40929 is a medium-severity vulnerability in RURBAN Cpanel::JSON::XS, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-40929 and fix it if it is affected.\n\nWhat it is: CVE-2025-40929 is a medium-severity vulnerability in RURBAN Cpanel::JSON::XS, published on 8 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-40929 in the wild and no public exploit code.\n\nAffected product: RURBAN Cpanel::JSON::XS. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-40929/ (Markdown: https://insights.sbomify.com/CVE-2025-40929/index.md)","id":"CVE-2025-40929","markdown":"https://insights.sbomify.com/CVE-2025-40929/index.md","name":"CVE-2025-40929","record":{"aliases":["ALPINE-CVE-2025-40929","AZL-67086","AZL-67088","DEBIAN-CVE-2025-40929","DLA-4318-1","DSA-6000-1","GHSA-q7gx-445j-xwq8","MGASA-2025-0284","OESA-2025-2241","OESA-2025-2242","SUSE-SU-2025:03193-1","UBUNTU-CVE-2025-40929","USN-7749-1","openSUSE-SU-2025:15534-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl JSON library","requires_auth":"none","summary":"An integer buffer overflow in the Cpanel::JSON::XS Perl library allows attackers to cause a denial of service via crafted JSON input.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[],"cvss":{"score":5.6,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Cpanel::JSON::XS before version 4.40 for Perl has an integer buffer overflow causing a segfault when parsing crafted JSON, enabling denial-of-service attacks or other unspecified impact","ecosystems":["SUSE:Linux Enterprise Module for Package Hub 15 SP7","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in Cpanel::JSON::XS","id":"CVE-2025-40929","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Integer overflow in JSON::SIMD","id":"CVE-2025-40930"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["4.380.0-150700.3.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-Cpanel-JSON-XS","purl":"pkg:rpm/suse/perl-Cpanel-JSON-XS\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2025:03193-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.400.0-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-Cpanel-JSON-XS","purl":"pkg:rpm/opensuse/perl-Cpanel-JSON-XS\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15534-1"}],"prev":{"headline":"Integer overflow in JSON::XS","id":"CVE-2025-40928"},"products":["Cpanel::JSON::XS"],"published":"2025-09-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["RURBAN"]},"summary":"An integer buffer overflow in the Cpanel::JSON::XS Perl library allows attackers to cause a denial of service via crafted JSON input.","url":"https://insights.sbomify.com/CVE-2025-40929/"}