{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-4101 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-4101 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-4101 is a medium-severity missing authorization vulnerability in wcmp MultiVendorX – WooCommerce Multivendor Marketplace Solutions, published on 17 May 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-4101 and fix it if it is affected.\n\nWhat it is: CVE-2025-4101 is a medium-severity missing authorization vulnerability in wcmp MultiVendorX – WooCommerce Multivendor Marketplace Solutions, published on 17 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-4101 in the wild and no public exploit code.\n\nAffected product: wcmp MultiVendorX – WooCommerce Multivendor Marketplace Solutions. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-4101/ (Markdown: https://insights.sbomify.com/CVE-2025-4101/index.md)","id":"CVE-2025-4101","markdown":"https://insights.sbomify.com/CVE-2025-4101/index.md","name":"CVE-2025-4101","record":{"aliases":["GHSA-8743-487v-2xqh"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated contributors can delete arbitrary posts and products due to incorrect authorization checks in the MultiVendorX WooCommerce plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"multivendorx","vendor":"multivendorx"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"The MultiVendorX – WooCommerce Multivendor Marketplace Solutions plugin for WordPress is vulnerable to unauthorized loss of data due to a misconfigured capability check on the 'delete_fpm_product' function in all versions up to, and including, 4.2.22. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary posts, pages, attachments, and products. The vulnerability was partially patched in version 4.2.22.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Missing authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions","id":"CVE-2025-4101","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"Beaver Builder Plugin (Starter Version) \u003c= 2.9.1 - Authenticated (Administrator+) Arbitrary File Upload","id":"CVE-2025-4102"},"packages":[],"prev":{"headline":"Nautic Pages \u003c= 2.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","id":"CVE-2025-4100"},"products":["MultiVendorX – WooCommerce Multivendor Marketplace Solutions"],"published":"2025-05-17","related":[{"cvss_score":9.8,"headline":"Path traversal in MultiVendorX – WooCommerce Multivendor Marketplace Solutions","id":"CVE-2025-0493","kev_date_added":null,"published":"2025-01-31"},{"cvss_score":9.8,"headline":"Missing authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions","id":"CVE-2024-8289","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":7.5,"headline":"WordPress MultiVendorX plugin \u003c= 4.2.22 - Sensitive Data Exposure Vulnerability","id":"CVE-2025-48261","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":7.1,"headline":"WordPress MultiVendorX Marketplace \u003c= 4.1.3 - Broken Access Control vulnerability","id":"CVE-2024-31304","kev_date_added":null,"published":"2024-06-09"},{"cvss_score":6.5,"headline":"WordPress MultiVendorX plugin \u003c= 4.2.22 - Cross Site Scripting (XSS) Vulnerability","id":"CVE-2025-48263","kev_date_added":null,"published":"2025-05-19"},{"cvss_score":6.4,"headline":"Cross-site scripting in MultiVendorX – WooCommerce Multivendor Marketplace Solutions","id":"CVE-2024-5259","kev_date_added":null,"published":"2024-06-06"},{"cvss_score":6.3,"headline":"Cross-site request forgery in MultiVendorX – WooCommerce Multivendor Marketplace Solutions","id":"CVE-2024-9943","kev_date_added":null,"published":"2024-10-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["wcmp"]},"summary":"Authenticated contributors can delete arbitrary posts and products due to incorrect authorization checks in the MultiVendorX WooCommerce plugin.","url":"https://insights.sbomify.com/CVE-2025-4101/"}